登陆

华为S5700交换机怎么装备链路聚合

admin 2019-10-27 233人围观 ,发现0个评论

配置手工负载分担模式链路聚合示例

组网需求

如图1所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。

用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

图1 配置手工负载分担模式链路聚合组网图

配置思路

采用如下的思路配置负载分担链路聚合:

创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。

说明:

接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLAN1中退出或将接口Shutdown,避免出现广播风暴。

创建VLAN并将接口加入VLAN。

配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

操作步骤

在SwitchA创建Eth-Trunk接口并加入成员接口。SwitchB配置与SwitchA类似,不再赘述。

system-view

[HUAWEI] sysname SwitchA

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3

[SwitchA-Eth-Trun华为S5700交换机怎么装备链路聚合k1] quit

创建VLAN并将接口加入VLAN。SwitchB配置与SwitchA类似,不再赘华为S5700交换机怎么装备链路聚合述。

# 创建VLAN10和VLAN20并分别加入接口。

[SwitchA] vlan batch 10 20

[SwitchA] interface gigabitethernet 0/0/4

[SwitchA-GigabitE华为S5700交换机怎么装备链路聚合thernet0/0/4] port link-type trunk

[SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet0/0/4] quit

[SwitchA] interface gigabitethernet 0/0/5

[SwitchA-GigabitEthernet0/0/5] port link-type trunk

[SwitchA-GigabitEthernet0/0/5] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet0/0/5] quit

# 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] port link-type trunk

[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20

配置Eth-Trunk1的负载分担方式。SwitchB配置与SwitchA类似,不再赘述。

[SwitchA-Eth-Trunk1] load-balance src-dst-mac

[SwitchA-Eth-Trunk1] quit

配置LACP模式的链路聚合示例

组网需求

如图1所示,在两台Switch设备上配置LACP模式链路聚合组,提高两设备之间的带宽与可靠性,具体要求如下:

两条活动链路具有负载分担的能力华为S5700交换机怎么装备链路聚合。

两设备间的链路具有1条冗余备份链路,当活动链路出现故障链路时,备份链路替代故障链路,保持数据传输的可靠性。

图1 配置LACP模式链路聚合组网图

配置思路

采用如下的思路配置LACP模式链路聚合:

创建Eth-Trunk,配置Eth-Trunk为LACP模式,实现链路聚合功能。

将成员接口加入Eth-Trunk。

说明:

接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLAN1中退出或将接口Shutdown,避免出现广播风暴。

配置系统优先级,确定主动端,按照主动端设备的接口选择活动接口。

配置活动接口上限阈值,实现保证带宽的情况下提高网络的可靠性。

配置接口优先级,确定活动链路接口,优先级高的接口将被选作活动接口。

操作华为S5700交换机怎么装备链路聚合步骤

在SwitchA上创建Eth-Trunk1并配置为LACP模式。SwitchB配置过程与SwitchA类似,不再赘述

system-view

[HUAWEI] sysname SwitchA

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] mode lacp

[SwitchA-Eth-Trunk1] quit

配置SwitchA上的成员接口加入Eth-Trunk。SwitchB配置过程与SwitchA类似,不再赘述

[SwitchA] interface gigabitethernet 0/0/1

[SwitchA-GigabitEthernet0/0/1] eth-trunk 1

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet 0/0/2

[SwitchA-GigabitEthernet0/0/2] eth-trunk 1

[SwitchA-GigabitEthernet0/0/2] quit

[SwitchA] interface gigabitethernet 0/0/3

[SwitchA-GigabitEthernet0/0/3] eth-trunk 1

[SwitchA-GigabitEthernet0/0/3] quit

在SwitchA上配置系统优先级为100,使其成为LACP主动端

[SwitchA] lacp priority 100

在SwitchA上配置活动接口上限阈值为2

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] max active-linknumber 2

[Switch色戒2A-Eth-Trunk1] quit

在SwitchA上配置接口优先级确定活动链路

[SwitchA] interface gigabitethernet 0/0/1

[SwitchA-GigabitEthernet0/0/1] lacp priority 100

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet 0/0/2

[SwitchA-GigabitEthernet0/0/2] lacp priority 100

[SwitchA-GigabitEthernet0/0/2] quit

请关注微信公众号
微信二维码
不容错过
Powered By Z-BlogPHP